import re
regex = re.compile(r"const {(?s)(.*)}.*?(?=const)", flags=re.MULTILINE)
test_str = ("const {\n"
" b {\n"
" description \"Create B1\"\n"
" uri \"ms:///a/v1/create-b\"\n"
" }\n"
" c {\n"
" description \"Create C1\"\n"
" uri \"ms:///a/v1/create-c\"\n"
" }\n"
" d {\n"
" description \"Create D1\"\n"
" uri \"ms:///a/v1/create-d\"\n"
" }\n"
"}\n\n"
"const {\n"
" b {\n"
" description \"Create B2\"\n"
" uri \"ms:///a/v1/create-b\"\n"
" }\n"
" c {\n"
" description \"Create C2\"\n"
" uri \"ms:///a/v1/create-c\"\n"
" }\n"
" d {\n"
" description \"Create D2\"\n"
" uri \"ms:///a/v1/create-d\"\n"
" }\n"
"}\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")