$re = '/\bQ(?=.*[0-9])[A-Z0-9]{7}\b/m';
$str = 'some words before QC1589ZH some words before Q1234567 QUANTITY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);