re = /\bQ(?=.*[0-9])[A-Z0-9]{7}\b/m
str = 'some words before QC1589ZH some words before Q1234567 QUANTITY'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end