$re = '/^\p{Latin}+$/m';
$str = 'delaÃ
aoeu
oeuärē
aaaà
2323442
üúôÆaaë';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);