#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\#)\d*"
Local $sString = "[1518-11-01 00:00] Guard #10 begins shift" & @CRLF & _
"[1518-11-01 00:05] falls asleep" & @CRLF & _
"[1518-11-01 00:25] wakes up" & @CRLF & _
"[1518-11-01 00:30] falls asleep" & @CRLF & _
"[1518-11-01 00:55] wakes up" & @CRLF & _
"[1518-11-01 23:58] Guard #99 begins shift" & @CRLF & _
"[1518-11-02 00:40] falls asleep" & @CRLF & _
"[1518-11-02 00:50] wakes up" & @CRLF & _
"[1518-11-03 00:05] Guard #10 begins shift" & @CRLF & _
"[1518-11-03 00:24] falls asleep" & @CRLF & _
"[1518-11-03 00:29] wakes up" & @CRLF & _
"[1518-11-04 00:02] Guard #99 begins shift" & @CRLF & _
"[1518-11-04 00:36] falls asleep" & @CRLF & _
"[1518-11-04 00:46] wakes up" & @CRLF & _
"[1518-11-05 00:03] Guard #99 begins shift" & @CRLF & _
"[1518-11-05 00:45] falls asleep" & @CRLF & _
"[1518-11-05 00:55] wakes up" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")