import re
regex = re.compile(r"(?<=\#)\d*", flags=re.MULTILINE)
test_str = ("[1518-11-01 00:00] Guard #10 begins shift\n"
"[1518-11-01 00:05] falls asleep\n"
"[1518-11-01 00:25] wakes up\n"
"[1518-11-01 00:30] falls asleep\n"
"[1518-11-01 00:55] wakes up\n"
"[1518-11-01 23:58] Guard #99 begins shift\n"
"[1518-11-02 00:40] falls asleep\n"
"[1518-11-02 00:50] wakes up\n"
"[1518-11-03 00:05] Guard #10 begins shift\n"
"[1518-11-03 00:24] falls asleep\n"
"[1518-11-03 00:29] wakes up\n"
"[1518-11-04 00:02] Guard #99 begins shift\n"
"[1518-11-04 00:36] falls asleep\n"
"[1518-11-04 00:46] wakes up\n"
"[1518-11-05 00:03] Guard #99 begins shift\n"
"[1518-11-05 00:45] falls asleep\n"
"[1518-11-05 00:55] wakes up\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")