#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(?P<modifiers>(?:\s*(?:private|const|static))*)\s*(?P<fulltype>(?P<type>[^\s<\[{]+)\s*(?P<generics><\s*.+\s*>)?)\s+(?P<name>[^\s<{]+)\s*(?:=\s*(?P<value>.+))?$"
Local $sString = " MyClass name" & @CRLF & _
" private MyClass name" & @CRLF & _
" MyClass < T , U > name" & @CRLF & _
" MyClass < T < U > > name" & @CRLF & _
" private static MyClass < T > name" & @CRLF & _
" private static MyClass < T < U > > name" & @CRLF & _
"" & @CRLF & _
"InputDeviceCharacteristics handCharL = InputDeviceCharacteristics.Controller | InputDeviceCharacteristics.Left" & @CRLF & _
"const float ResizeSpeed = 0.5f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")