import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?P<modifiers>(?:\\s*(?:private|const|static))*)\\s*(?P<fulltype>(?P<type>[^\\s<\\[\\{]+)\\s*(?P<generics><\\s*.+\\s*>)?)\\s+(?P<name>[^\\s<\\{]+)\\s*(?:=\\s*(?P<value>.+))?$";
final String string = " MyClass name\n"
+ " private MyClass name\n"
+ " MyClass < T , U > name\n"
+ " MyClass < T < U > > name\n"
+ " private static MyClass < T > name\n"
+ " private static MyClass < T < U > > name\n\n"
+ "InputDeviceCharacteristics handCharL = InputDeviceCharacteristics.Controller | InputDeviceCharacteristics.Left\n"
+ "const float ResizeSpeed = 0.5f";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}