import re
regex = re.compile(r"(\"|')((?!(?!\\)(\1|\n))|(\\(.|\n))|((?!\\).))*?(\1)")
test_str = ("\"valid line\"\n\n"
"'valid line 2'\n\n"
"''\n\n"
"\"\"\n\n"
"\"'''\"\n"
"\"''''\"\n"
"'\"\"\"'\n"
"'\"\"\"\"'\n\n"
"\"hello new line\\\n"
"hello another line\\\n"
"end blank line\"\n\n"
"'hello blank line\\\n"
"\\ \\\\g\\\n"
"end blank line'\n\n"
"\"\\'\"\n\n"
"\"\\\"\"\n\n"
"\"errors\"\n\n"
"\"broken line\n"
"\"\n\n"
"'broken line \n"
"'\n\n"
"\"broken line 2 \\ffd\n"
"\\hellod\n"
"\"\n"
"'\\'\n"
"\"\\\"\n"
"\"\"\"\n\n"
"'''\n")
subst = "newstr"
result = regex.sub(subst, test_str)
if result:
print(result)