#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\A(?:(?:[\s\d]*[acgt]){3}){247}\K(?:[\s\d]*[acgt]){3}"
Local $sString = " atggagga gccgcagtca gatcctagcg tcgagccccc" & @CRLF & _
" 241 tctgagtcag gaaacatttt cagacctatg gaaactactt cctgaaaaca acgttctgtc" & @CRLF & _
" 301 ccccttgccg tcccaagcaa tggatgattt gatgctgtcc ccggacgata ttgaacaatg" & @CRLF & _
" 361 gttcactgaa gacccaggtc cagatgaagc tcccagaatg ccagaggctg ctccccccgt" & @CRLF & _
" 421 ggcccctgca ccagcagctc ctacaccggc ggcccctgca ccagccccct cctggcccct" & @CRLF & _
" 481 gtcatcttct gtcccttccc agaaaaccta ccagggcagc tacggtttcc gtctgggctt" & @CRLF & _
" 541 cttgcattct gggacagcca agtctgtgac ttgcacgtac tcccctgccc tcaacaagat" & @CRLF & _
" 601 gttttgccaa ctggccaaga cctgccctgt gcagctgtgg gttgattcca cacccccgcc" & @CRLF & _
" 661 cggcacccgc gtccgcgcca tggccatcta caagcagtca cagcacatga cggaggttgt" & @CRLF & _
" 721 gaggcgctgc ccccaccatg agcgctgctc agatagcgat ggtctggccc ctcctcagca" & @CRLF & _
" 781 tcttatccga gtggaaggaa atttgcgtgt ggagtatttg gatgacagaa acacttttcg" & @CRLF & _
" 841 acatagtgtg gtggtgccct atgagccgcc tgaggttggc tctgactgta ccaccatcca" & @CRLF & _
" 901 ctacaactac atgtgtaaca gttcctgcat gggcggcatg aaccggaggc ccatcctcac" & @CRLF & _
" 961 catcatcaca ctggaagact ccagtggtaa tctactggga cggaacagct ttgaggtgcg" & @CRLF & _
" 1021 tgtttgtgcc tgtcctggga gagaccggcg cacagaggaa gagaatctcc gcaagaaagg" & @CRLF & _
" 1081 ggagcctcac cacgagctgc ccccagggag cactaagcga gcactgccca acaacaccag" & @CRLF & _
" 1141 ctcctctccc cagccaaaga agaaaccact ggatggagaa tatttcaccc ttcagatccg" & @CRLF & _
" 1201 tgggcgtgag cgcttcgaga tgttccgaga gctgaatgag gccttggaac tcaaggatgc" & @CRLF & _
" 1261 ccaggctggg aaggagccag gggggagcag ggctcactcc agccacctga agtccaaaaa" & @CRLF & _
" 1321 gggtcagtct acctcccgcc ataaaaaact catgttcaag acagaagggc ctgactcaga" & @CRLF & _
" 1381 ctga"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")