import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(?:(?:[\\s\\d]*[acgt]){3}){247}\\K(?:[\\s\\d]*[acgt]){3}";
final String string = " atggagga gccgcagtca gatcctagcg tcgagccccc\n"
+ " 241 tctgagtcag gaaacatttt cagacctatg gaaactactt cctgaaaaca acgttctgtc\n"
+ " 301 ccccttgccg tcccaagcaa tggatgattt gatgctgtcc ccggacgata ttgaacaatg\n"
+ " 361 gttcactgaa gacccaggtc cagatgaagc tcccagaatg ccagaggctg ctccccccgt\n"
+ " 421 ggcccctgca ccagcagctc ctacaccggc ggcccctgca ccagccccct cctggcccct\n"
+ " 481 gtcatcttct gtcccttccc agaaaaccta ccagggcagc tacggtttcc gtctgggctt\n"
+ " 541 cttgcattct gggacagcca agtctgtgac ttgcacgtac tcccctgccc tcaacaagat\n"
+ " 601 gttttgccaa ctggccaaga cctgccctgt gcagctgtgg gttgattcca cacccccgcc\n"
+ " 661 cggcacccgc gtccgcgcca tggccatcta caagcagtca cagcacatga cggaggttgt\n"
+ " 721 gaggcgctgc ccccaccatg agcgctgctc agatagcgat ggtctggccc ctcctcagca\n"
+ " 781 tcttatccga gtggaaggaa atttgcgtgt ggagtatttg gatgacagaa acacttttcg\n"
+ " 841 acatagtgtg gtggtgccct atgagccgcc tgaggttggc tctgactgta ccaccatcca\n"
+ " 901 ctacaactac atgtgtaaca gttcctgcat gggcggcatg aaccggaggc ccatcctcac\n"
+ " 961 catcatcaca ctggaagact ccagtggtaa tctactggga cggaacagct ttgaggtgcg\n"
+ " 1021 tgtttgtgcc tgtcctggga gagaccggcg cacagaggaa gagaatctcc gcaagaaagg\n"
+ " 1081 ggagcctcac cacgagctgc ccccagggag cactaagcga gcactgccca acaacaccag\n"
+ " 1141 ctcctctccc cagccaaaga agaaaccact ggatggagaa tatttcaccc ttcagatccg\n"
+ " 1201 tgggcgtgag cgcttcgaga tgttccgaga gctgaatgag gccttggaac tcaaggatgc\n"
+ " 1261 ccaggctggg aaggagccag gggggagcag ggctcactcc agccacctga agtccaaaaa\n"
+ " 1321 gggtcagtct acctcccgcc ataaaaaact catgttcaag acagaagggc ctgactcaga\n"
+ " 1381 ctga";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}