#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ *\d[\d ]*$"
Local $sString = "1" & @CRLF & _
"2 3" & @CRLF & _
" 3 56" & @CRLF & _
"8888888 333" & @CRLF & _
" 039" & @CRLF & _
"" & @CRLF & _
"not OK:" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"4 e" & @CRLF & _
"874 1231 88 qqqq 99" & @CRLF & _
" shf ie sh f 8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")