package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *\d[\d ]*$`)
var str = `1
2 3
3 56
8888888 333
039
not OK:
a
4 e
874 1231 88 qqqq 99
shf ie sh f 8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}