#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(#(?!thankyouburger)[\w]+)"
Local $sString = "" & @CRLF & _
"This guy makes my world turn and is my hero. He's #rescued. me from some of my darkest days and has been my champion through my struggles with combat related PTSD. I love you the mosterest, D1. 💚 #thankyouburger #dsdsfgd #sdfsdf #sdsfdfs, #sdffs"
Local $sSubst = "($1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)