#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)\(" & @CRLF & _
"(?=" & @CRLF & _
" (?:\.*\(){24}" & @CRLF & _
" (.*)" & @CRLF & _
")" & @CRLF & _
"(?<=" & @CRLF & _
" (?=" & @CRLF & _
" (\(*(?:\.\(*){0,15})" & @CRLF & _
" \1$" & @CRLF & _
" )" & @CRLF & _
" \(" & @CRLF & _
")"
Local $sString = "...((((((((.(((..((..((((.(((((((.(..(((((.(((.(((...))).))).)))))..)..))))))).))))..))..))).))))))))(((.((.(((((...((........))))))))))))............"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")