re = /\(
(?=
(?:\.*\(){24}
(.*)
)
(?<=
(?=
(\(*(?:\.\(*){0,15})
\1$
)
\(
)/mx
str = '...((((((((.(((..((..((((.(((((((.(..(((((.(((.(((...))).))).)))))..)..))))))).))))..))..))).))))))))(((.((.(((((...((........))))))))))))............'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end