#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?<!\bbad\b[^.])\bgood\b(?![^.]+\bbad\b)"
Local $sString = "A good example of a bad regex." & @CRLF & _
"A bad example of a good regex." & @CRLF & _
"A bad example. A good regex." & @CRLF & _
"A good example. A bad regex."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")