import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\bbad\\b[^.])\\bgood\\b(?![^.]+\\bbad\\b)";
final String string = "A good example of a bad regex.\n"
+ "A bad example of a good regex.\n"
+ "A bad example. A good regex.\n"
+ "A good example. A bad regex.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}