using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(\d+)";
string input = @"[1518-11-01 00:00] Guard #10 begins shift";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}