$re = '/#(\d+)/m';
$str = '[1518-11-01 00:00] Guard #10 begins shift';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);