$re = '/(?<=>\n).*(?=<\/a>)/m';
$str = '<span itemprop="author">
<a href="/author/sigrid-unset/">
Сигрид Унсет</a> </span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);