re = /(?<=>\n).*(?=<\/a>)/m
str = '<span itemprop="author">
<a href="/author/sigrid-unset/">
Сигрид Унсет</a> </span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end