using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[+([a-z- A-Z]+)\]+";
string input = @"[[[hello-hello]],[[hi-hi]]] [[hi hi]]]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}