package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[+([a-z- A-Z]+)\]+`)
var str = `[[[hello-hello]],[[hi-hi]]] [[hi hi]]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}