$re = '/^([0-9]?[0-9]?|[1-2]?[0-9]?[0-9]?|[0-3]?[0-6]?[0-9]|360)?°?\s?([0-5]?[0-9])?\'?\s?([0-5]?[0-9](,[0-9])?)?"?$/m';
$str = '359° 59\' 0"
190° 0\'
190°
250°
125° 59\' 59"
0° 0\' 0"
90° 0\' 0"
2° 1\' 3"
390°
1000° 1\' 2"
360° 0\' 0"
361° 61\' 61"
180° 0\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);