import Foundation
let pattern = #"^([0-9]?[0-9]?|[1-2]?[0-9]?[0-9]?|[0-3]?[0-6]?[0-9]|360)?°?\s?([0-5]?[0-9])?'?\s?([0-5]?[0-9](,[0-9])?)?"?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
359° 59' 0"
190° 0'
190°
250°
125° 59' 59"
0° 0' 0"
90° 0' 0"
2° 1' 3"
390°
1000° 1' 2"
360° 0' 0"
361° 61' 61"
180° 0'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)