package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^-]+-[^-]+-(.+)-([^-]+)$`)
var str = `SKU-PRODUCT-BLUE-1
SKU-PRODUCT-RED-1
SKU-PRODUCT-WHITE-1
SKU-PRODUCT-BABY-BLUE-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}