$re = '/^[^-]+-[^-]+-(.+)-([^-]+)$/m';
$str = 'SKU-PRODUCT-BLUE-1
SKU-PRODUCT-RED-1
SKU-PRODUCT-WHITE-1
SKU-PRODUCT-BABY-BLUE-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);