re = /[\s]*(?i)((delete)|(exec)|(drop\s*table)|(insert)|(shutdown)|(update)|(\bor\b))/m
str = 'Description: change name
Description: update name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end