#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\(\[].*?[\)\]]"
Local $sString = "[Part 1: A]" & @CRLF & _
"Was hab’ ich nur getan?" & @CRLF & _
"Hab mich selbst nie hinterfragt" & @CRLF & _
"Wer bin ich, wer bin ich, wer bin ich, was bin ich bloß?" & @CRLF & _
"Aaaah - wer bin ich, was bin ich bloß?" & @CRLF & _
"Ging es all die Zeit lang wirklich nur um mich?" & @CRLF & _
"Nur um mich, nur um mich, nur um mich?" & @CRLF & _
"Denk’ ich wirklich immer nur an mich?" & @CRLF & _
"Nur an mich, nur an mich, nur an mich?" & @CRLF & _
"" & @CRLF & _
"[Part 2: T]" & @CRLF & _
"Ich bin so horrible, horrible, horrible" & @CRLF & _
"Fehler einzusehen ist mir nicht possible, possible, possible" & @CRLF & _
"Jaaah - doch ich denk’ jeden Tag an all den Shit, den ich getan hab’" & @CRLF & _
"Warum unterschätz’ ich meinen Impact auf die andern?" & @CRLF & _
"Homie, sag mir, warum ficke ich mein Karma" & @CRLF & _
"Und geb kein’ Fick auf alles, was die Stimme in mir labert?" & @CRLF & _
"Blockiert mich da mein Ego oder weiß ich es nicht besser?" & @CRLF & _
"Mann, wann verdammt fühl ich mich bereit etwas zu ändern?" & @CRLF & _
"Warum lass’ ich einfach nichts mehr an mich ran?" & @CRLF & _
"Warum lass’ ich selbst mich selbst nicht an mich ran?" & @CRLF & _
",1" & @CRLF & _
"" & @CRLF & _
"(...)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")