import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\(\\[].*?[\\)\\]]";
final String string = "[Part 1: A]\n"
+ "Was hab’ ich nur getan?\n"
+ "Hab mich selbst nie hinterfragt\n"
+ "Wer bin ich, wer bin ich, wer bin ich, was bin ich bloß?\n"
+ "Aaaah - wer bin ich, was bin ich bloß?\n"
+ "Ging es all die Zeit lang wirklich nur um mich?\n"
+ "Nur um mich, nur um mich, nur um mich?\n"
+ "Denk’ ich wirklich immer nur an mich?\n"
+ "Nur an mich, nur an mich, nur an mich?\n\n"
+ "[Part 2: T]\n"
+ "Ich bin so horrible, horrible, horrible\n"
+ "Fehler einzusehen ist mir nicht possible, possible, possible\n"
+ "Jaaah - doch ich denk’ jeden Tag an all den Shit, den ich getan hab’\n"
+ "Warum unterschätz’ ich meinen Impact auf die andern?\n"
+ "Homie, sag mir, warum ficke ich mein Karma\n"
+ "Und geb kein’ Fick auf alles, was die Stimme in mir labert?\n"
+ "Blockiert mich da mein Ego oder weiß ich es nicht besser?\n"
+ "Mann, wann verdammt fühl ich mich bereit etwas zu ändern?\n"
+ "Warum lass’ ich einfach nichts mehr an mich ran?\n"
+ "Warum lass’ ich selbst mich selbst nicht an mich ran?\n"
+ ",1\n\n"
+ "(...)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}