use strict;
my $str = 'FR_3000 Error opening file [File_Location]. Operating system error message [The system cannot find the path specified.].';
my $regex = qr/^(.*?)\[.*?\](.*)$/mp;
my $subst = '\\1[]\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";