$re = '/^(.*?)\[.*?\](.*)$/m';
$str = 'FR_3000 Error opening file [File_Location]. Operating system error message [The system cannot find the path specified.].';
$subst = "\1[]\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;