package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[IO]\d{3,}(\w{12})`)
var str = `2:O5641057130214TESTBIC34XXX26264938281302141757N
2:I101YOURBANKXJKLU3003`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}