// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[IO]\d{3,}(\w{12})").unwrap();
let string = "2:O5641057130214TESTBIC34XXX26264938281302141757N
2:I101YOURBANKXJKLU3003";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}