const regex = /(?<=\(INR\))(.|\n)*(?=Due Date)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\(INR\\))(.|\\n)*(?=Due Date)', 'gm')
const str = `Format : ExpoHub
123456789
expohub street
ABC
123456
India
Billed To Date of Issue Invoice Number Amount Due (INR)
Nagesh Reddy. 22/04/2020 873101. Rs.26,178.00
Due Date
22/05/2020
Description Rate Qty Line Total
Shared Hosting Rs.25,878.00 1 Rs.25,878.00
LateFee Rs.300.00 1 Rs.300.00
Rs.0.00 1 Rs.0.00
Subtotal 26,178.00
Tax 0.00
Total
Amount Paid
26,178.00
0.00
Amount Due (INR) Rs.26,178.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}