use strict;
my $str = 'Format : ExpoHub
123456789
expohub street
ABC
123456
India
Billed To Date of Issue Invoice Number Amount Due (INR)
Nagesh Reddy. 22/04/2020 873101. Rs.26,178.00
Due Date
22/05/2020
Description Rate Qty Line Total
Shared Hosting Rs.25,878.00 1 Rs.25,878.00
LateFee Rs.300.00 1 Rs.300.00
Rs.0.00 1 Rs.0.00
Subtotal 26,178.00
Tax 0.00
Total
Amount Paid
26,178.00
0.00
Amount Due (INR) Rs.26,178.00';
my $regex = qr/(?<=\(INR\))(.|\n)*(?=Due Date)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}