package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http[s]?://((?:[a-zA-Z]|[0-9]|[$_@.&+-]|[!*\(\),]|(?:%[0-9a-fA-F][0-9a-fA-F]))+)`)
var str = `http://test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}