re = /http[s]?:\/\/((?:[a-zA-Z]|[0-9]|[$_@.&+-]|[!*\(\),]|(?:%[0-9a-fA-F][0-9a-fA-F]))+)/m
str = 'http://test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end