package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)([a-z][a-zA-Z0-9-]*)=(?:'([^\\']*(?:\\.[^\\']*)*)'|"([^"\\]*(?:\\.[^"\\]*)*)")`)
var str = `a="xyz" b="hello world"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}