$re = '/(?s)([a-z][a-zA-Z0-9-]*)=(?:\'([^\\\\\']*(?:\\\\.[^\\\\\']*)*)\'|"([^"\\\\]*(?:\\\\.[^"\\\\]*)*)")/';
$str = 'a="xyz" b="hello world"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);