#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:1()|2()|3())/sometext/sometext/(?:\1first|\2second|\3third)$"
Local $sString = "1/sometext/sometext/first" & @CRLF & _
"1/sometext/sometext/second" & @CRLF & _
"1/sometext/sometext/third" & @CRLF & _
"2/sometext/sometext/first" & @CRLF & _
"2/sometext/sometext/second" & @CRLF & _
"2/sometext/sometext/third" & @CRLF & _
"3/sometext/sometext/first" & @CRLF & _
"3/sometext/sometext/second" & @CRLF & _
"3/sometext/sometext/third" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")