$re = '~^(?:1()|2()|3())/sometext/sometext/(?:\1first|\2second|\3third)$~m';
$str = '1/sometext/sometext/first
1/sometext/sometext/second
1/sometext/sometext/third
2/sometext/sometext/first
2/sometext/sometext/second
2/sometext/sometext/third
3/sometext/sometext/first
3/sometext/sometext/second
3/sometext/sometext/third
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);