#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\d{4}\.\d{3}\.\d{3}.*).*\n(.+)"
Local $sString = "Number" & @CRLF & _
"5012993885" & @CRLF & _
"Transport" & @CRLF & _
"23943538" & @CRLF & _
"Contact person" & @CRLF & _
"Lenka Boček" & @CRLF & _
"E-Mail" & @CRLF & _
"Date" & @CRLF & _
"24.01.2024" & @CRLF & _
"" & @CRLF & _
"Telephone" & @CRLF & _
"00420 731316628" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Your VAT No." & @CRLF & _
"BG175423111" & @CRLF & _
" " & @CRLF & _
"Shipment by" & @CRLF & _
"Parcel service" & @CRLF & _
"Forwarder" & @CRLF & _
"UPS United Parcel Service" & @CRLF & _
"Item Part Number" & @CRLF & _
"Description" & @CRLF & _
"Suffix Quantity" & @CRLF & _
"Piece" & @CRLF & _
"Price/ " & @CRLF & _
"EUR " & @CRLF & _
" Per" & @CRLF & _
" PCE" & @CRLF & _
"Disc.% Amount" & @CRLF & _
"EUR" & @CRLF & _
"Customer Material / Material entered / OE-Number" & @CRLF & _
"Transport: 23943538" & @CRLF & _
"Order No.: 3192166 Your Reference: A202401241118" & @CRLF & _
" 11 4149.310.025 000 1 37,78 1 37,78 " & @CRLF & _
"PISTON" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000141478" & @CRLF & _
" 21 0734.401.251 000 4 3,05 1 12,20 " & @CRLF & _
"PISTON RING" & @CRLF & _
"HS.code: 73182100 Country of origin: JP" & @CRLF & _
"EAN: 2050000026638" & @CRLF & _
" 31 0750.116.391 000 1 35,50 1 35,50 " & @CRLF & _
"BALL BEARING" & @CRLF & _
"HS.code: 84821090 Country of origin: JP" & @CRLF & _
"EAN: 2050000088643" & @CRLF & _
" 41 0634.314.358 000 1 5,57 1 5,57 " & @CRLF & _
"O-RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000017476" & @CRLF & _
" 51 0734.401.080 000 1 5,41 1 5,41 " & @CRLF & _
"PISTON RING" & @CRLF & _
"HS.code: 73182100 Country of origin: JP" & @CRLF & _
"EAN: 2050000028885" & @CRLF & _
" 61 4139.210.082 000 1 55,70 1 55,70 " & @CRLF & _
"BUSH" & @CRLF & _
"HS.code: 73182900 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000111631" & @CRLF & _
"Number 5012993885" & @CRLF & _
"Date 24.01.2024" & @CRLF & _
"carry forward 152,16 " & @CRLF & _
"Item Part Number" & @CRLF & _
"Description" & @CRLF & _
"Suffix Quantity" & @CRLF & _
"Piece" & @CRLF & _
"Price/ " & @CRLF & _
"EUR " & @CRLF & _
" Per" & @CRLF & _
" PCE" & @CRLF & _
"Disc.% Amount" & @CRLF & _
"EUR" & @CRLF & _
"Customer Material / Material entered / OE-Number" & @CRLF & _
" 71 0734.401.277 000 1 110,41 1 110,41 " & @CRLF & _
"RECTANGULAR RING" & @CRLF & _
"HS.code: 73182100 Country of origin: QU" & @CRLF & _
"EAN: 2050000103230" & @CRLF & _
" 81 0634.313.017 000 1 0,81 1 0,81 " & @CRLF & _
"O-RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000057557" & @CRLF & _
" 91 4149.320.018 000 1 79,19 1 79,19 " & @CRLF & _
"BUSH" & @CRLF & _
"HS.code: 76169990 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000144653" & @CRLF & _
" 101 0750.115.518 000 1 2,16 1 2,16 " & @CRLF & _
"NEEDLE SLEEVE" & @CRLF & _
"HS.code: 84824000 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000086328" & @CRLF & _
" 111 0730.150.625 000 1 3,67 1 3,67 " & @CRLF & _
"THRUST WASHER" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000082290" & @CRLF & _
" 121 0750.115.520 000 2 5,97 1 11,94 " & @CRLF & _
"NEEDLE CAGE" & @CRLF & _
"HS.code: 84824000 Country of origin: EU/SK" & @CRLF & _
"EAN: 2050000116179" & @CRLF & _
" 131 0730.150.638 000 1 5,98 1 5,98 " & @CRLF & _
"THRUST WASHER" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000104367" & @CRLF & _
" 141 0730.150.630 000 1 12,98 1 12,98 " & @CRLF & _
"THRUST WASHER" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000112317" & @CRLF & _
" 151 0735.320.782 000 2 8,76 1 17,52 " & @CRLF & _
"NEEDLE CAGE" & @CRLF & _
"HS.code: 84824000 Country of origin: EU/SK" & @CRLF & _
"EAN: 2050000060595" & @CRLF & _
" 161 0730.150.637 000 1 4,67 1 4,67 " & @CRLF & _
"THRUST WASHER" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000115325" & @CRLF & _
" 171 0730.150.636 000 1 6,82 1 6,82 " & @CRLF & _
"THRUST WASHER" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000082610" & @CRLF & _
" 181 0730.150.639 000 1 3,55 1 3,55 " & @CRLF & _
"THRUST WASHER" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000054846" & @CRLF & _
" 191 0750.115.519 000 1 4,06 1 4,06 " & @CRLF & _
"NEEDLE SLEEVE" & @CRLF & _
"HS.code: 84824000 Country of origin: US" & @CRLF & _
"EAN: 2050000080418" & @CRLF & _
" 201 4139.333.040 000 1 2,10 1 2,10 " & @CRLF & _
"FIXING PLATE" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000043369" & @CRLF & _
"Item Part Number" & @CRLF & _
"Description" & @CRLF & _
"Suffix Quantity" & @CRLF & _
"Piece" & @CRLF & _
"Price/ " & @CRLF & _
"EUR " & @CRLF & _
" Per" & @CRLF & _
" PCE" & @CRLF & _
"Disc.% Amount" & @CRLF & _
"EUR" & @CRLF & _
"Customer Material / Material entered / OE-Number" & @CRLF & _
" 211 0630.513.028 000 1 1,25 1 1,25 " & @CRLF & _
"SNAP RING" & @CRLF & _
"HS.code: 73182100 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000007927" & @CRLF & _
" 221 4139.333.373 000 1 18,43 1 18,43 " & @CRLF & _
"DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000055355" & @CRLF & _
" 231 4139.333.172 000 1 13,40 1 13,40 " & @CRLF & _
"O.CLUTCH DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000139765" & @CRLF & _
" 241 4139.333.036 000 1 4,55 1 4,55 " & @CRLF & _
"I.CLUTCH DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000132223" & @CRLF & _
" 251 4149.370.005 000 1 12,96 1 12,96 " & @CRLF & _
"O.CLUTCH DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000134135" & @CRLF & _
" 261 4139.333.437 000 1 18,36 1 18,36 " & @CRLF & _
"DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000071713" & @CRLF & _
" 271 4139.333.263 000 1 17,98 1 17,98 " & @CRLF & _
"O.CLUTCH DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000104916" & @CRLF & _
" 281 4139.333.745 000 3 17,05 1 51,15 " & @CRLF & _
"O.CLUTCH DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000143649" & @CRLF & _
" 291 4139.333.766 000 1 21,36 1 21,36 " & @CRLF & _
"O.CLUTCH DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000081705" & @CRLF & _
" 301 0734.307.302 000 1 18,92 1 18,92 " & @CRLF & _
"LIP SEALING RING" & @CRLF & _
"HS.code: 84842000 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000176593" & @CRLF & _
" 311 0734.300.504 000 1 15,46 1 15,46 " & @CRLF & _
"PISTON RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000174032" & @CRLF & _
" 321 0734.300.503 000 1 12,19 1 12,19 " & @CRLF & _
"PISTON RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000176807" & @CRLF & _
" 331 0750.117.625 000 1 31,26 1 31,26 " & @CRLF & _
"TAPERED ROLLER BEARING" & @CRLF & _
"HS.code: 84822000 Country of origin: CN" & @CRLF & _
"EAN: 2050000123405" & @CRLF & _
" 341 0730.103.590 000 1 2,79 1 2,79 " & @CRLF & _
"WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000109447" & @CRLF & _
"carry forward 658,08 4/7 " & @CRLF & _
"Item Part Number" & @CRLF & _
"Description" & @CRLF & _
"Suffix Quantity" & @CRLF & _
"Piece" & @CRLF & _
"Price/ " & @CRLF & _
"EUR " & @CRLF & _
" Per" & @CRLF & _
" PCE" & @CRLF & _
"Disc.% Amount" & @CRLF & _
"EUR" & @CRLF & _
"Customer Material / Material entered / OE-Number" & @CRLF & _
" 351 0730.103.589 000 1 2,00 1 2,00 " & @CRLF & _
"WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000099366" & @CRLF & _
" 361 0750.117.621 000 1 32,82 1 32,82 " & @CRLF & _
"TAPERED ROLLER BEARING" & @CRLF & _
"HS.code: 84822000 Country of origin: JP" & @CRLF & _
"EAN: 2050000124365" & @CRLF & _
" 371 0730.103.362 000 1 7,67 1 7,67 " & @CRLF & _
"SPACER WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000071355" & @CRLF & _
" 381 0730.008.417 000 1 3,02 1 3,02 " & @CRLF & _
"WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050006139165" & @CRLF & _
" 391 0730.008.418 000 1 3,02 1 3,02 " & @CRLF & _
"WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000101281" & @CRLF & _
" 401 0730.008.420 000 1 4,31 1 4,31 " & @CRLF & _
"WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000158292" & @CRLF & _
" 411 0730.008.423 000 1 3,02 1 3,02 " & @CRLF & _
"WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000052804" & @CRLF & _
" 421 0634.313.016 000 2 0,34 1 0,68 " & @CRLF & _
"O-RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000024382" & @CRLF & _
" 431 0730.002.769 000 7 0,74 1 5,18 " & @CRLF & _
"WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000109171" & @CRLF & _
" 441 0630.502.007 000 7 0,41 1 2,87 " & @CRLF & _
"CIRCLIP" & @CRLF & _
"HS.code: 73182100 Country of origin: CN" & @CRLF & _
"EAN: 2050000012969" & @CRLF & _
" 451 4139.306.217 000 7 7,95 1 55,65 " & @CRLF & _
"PIN" & @CRLF & _
"HS.code: 73170080 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000093951" & @CRLF & _
" 461 0501.214.850 000 1 68,29 1 68,29 " & @CRLF & _
"OIL DIPSTICK" & @CRLF & _
"HS.code: 90261089 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000096211" & @CRLF & _
" 471 4139.301.617 000 1 0,70 1 0,70 " & @CRLF & _
"TAB WASHER" & @CRLF & _
"HS.code: 73182100 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000084041" & @CRLF & _
" 481 0769.151.009 000 1 1,87 1 1,87 " & @CRLF & _
"O-RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050011096262" & @CRLF & _
"carry forward 849,18 5/7 " & @CRLF & _
"carry forward 849,18 " & @CRLF & _
"Item Part Number" & @CRLF & _
"Description" & @CRLF & _
"Suffix Quantity" & @CRLF & _
"Piece" & @CRLF & _
"Price/ " & @CRLF & _
"EUR " & @CRLF & _
" Per" & @CRLF & _
" PCE" & @CRLF & _
"Disc.% Amount" & @CRLF & _
"EUR" & @CRLF & _
"Customer Material / Material entered / OE-Number" & @CRLF & _
" 491 0501.210.798 000 1 10,08 1 10,08 " & @CRLF & _
"SCREEN INSERT" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000005534" & @CRLF & _
" 501 0735.368.102 000 1 70,18 1 70,18 " & @CRLF & _
"AXIAL ROLLER BEARING" & @CRLF & _
"HS.code: 84825000 Country of origin: EU/SK" & @CRLF & _
"EAN: 2050000123191" & @CRLF & _
" 511 0635.330.035 000 2 25,15 1 50,30 " & @CRLF & _
"BALL BEARING" & @CRLF & _
"HS.code: 84821090 Country of origin: IN" & @CRLF & _
"EAN: 2050000051746" & @CRLF & _
" 521 0635.900.523 000 1 8,94 1 8,94 " & @CRLF & _
"AX.NEEDLE CAGE" & @CRLF & _
"HS.code: 84829900 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000012099" & @CRLF & _
" 531 0634.402.140 000 1 3,22 1 3,22 " & @CRLF & _
"R-RING" & @CRLF & _
"HS.code: 73262000 Country of origin: JP" & @CRLF & _
"EAN: 2050000102523" & @CRLF & _
" 541 0501.213.150 000 2 52,97 1 105,94 " & @CRLF & _
"I.CLUTCH DISC" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/PL" & @CRLF & _
"EAN: 2050000017186" & @CRLF & _
" 551 0501.334.482 000 2 91,72 1 183,44 " & @CRLF & _
"OUTER CLUTCH DISK" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050011198423" & @CRLF & _
" 561 0501.334.483 000 2 116,68 1 233,36 " & @CRLF & _
"OUTER CLUTCH DISK" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050011198416" & @CRLF & _
" 571 0750.106.074 000 1 124,26 1 124,26 " & @CRLF & _
"CUP SPRING" & @CRLF & _
"HS.code: 73209030 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000062230" & @CRLF & _
" 581 0501.320.311 000 1 16,72 1 16,72 " & @CRLF & _
"SEALING RING" & @CRLF & _
"HS.code: 40169300 Country of origin: EU/IE" & @CRLF & _
"EAN: 2050000006746" & @CRLF & _
" 591 0501.320.312 000 1 27,75 1 27,75 " & @CRLF & _
"SEALING RING" & @CRLF & _
"HS.code: 40169300 Country of origin: EU/IE" & @CRLF & _
"EAN: 2050000021688" & @CRLF & _
" 601 0634.313.840 000 1 15,01 1 15,01 " & @CRLF & _
"O-RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000043406" & @CRLF & _
" 611 0736.101.046 000 1 3,91 1 3,91 " & @CRLF & _
"CAP SCREW" & @CRLF & _
"HS.code: 73181568 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000066542" & @CRLF & _
" 621 0730.005.592 000 1 11,45 1 11,45 " & @CRLF & _
"WASHER" & @CRLF & _
"HS.code: 73182200 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000028366" & @CRLF & _
"carry forward 1.713,74 6/7 " & @CRLF & _
"Item Part Number" & @CRLF & _
"Description" & @CRLF & _
"Suffix Quantity" & @CRLF & _
"Piece" & @CRLF & _
"Price/ " & @CRLF & _
"EUR " & @CRLF & _
" Per" & @CRLF & _
" PCE" & @CRLF & _
"Disc.% Amount" & @CRLF & _
"EUR" & @CRLF & _
"Customer Material / Material entered / OE-Number" & @CRLF & _
" 631 0634.313.628 000 2 1,76 1 3,52 " & @CRLF & _
"O-RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000092503" & @CRLF & _
" 641 0501.221.565 000 1 111,27 1 111,27 " & @CRLF & _
"PISTON" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050010978361" & @CRLF & _
" 651 4139.347.284 000 1 1,32 1 1,32 " & @CRLF & _
"GASKET" & @CRLF & _
"HS.code: 40169300 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000074042" & @CRLF & _
" 661 4139.347.275 000 2 0,69 1 1,38 " & @CRLF & _
"GASKET" & @CRLF & _
"HS.code: 40169300 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050005683713" & @CRLF & _
" 671 4139.347.273 000 2 77,93 1 155,86 " & @CRLF & _
"CONN.PART" & @CRLF & _
"HS.code: 87084099 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050001798787" & @CRLF & _
" 681 4139.298.939 009 1 52,37 1 52,37 " & @CRLF & _
"SEALING RING KIT" & @CRLF & _
"HS.code: 84849000 Country of origin: EU/DE" & @CRLF & _
"EAN: 4053202129457" & @CRLF & _
" 691 4139.298.943 009 1 115,37 1 115,37 " & @CRLF & _
"SEAL KIT" & @CRLF & _
"HS.code: 84849000 Country of origin: EU/DE" & @CRLF & _
"EAN: 4053202129426" & @CRLF & _
"Goods value: 2.154,83 " & @CRLF & _
"Freight charges 14,45 " & @CRLF & _
"Transport: 23943551" & @CRLF & _
" 711 0630.361.026 000 1 6,82 1 6,82 " & @CRLF & _
"SEALING CAP" & @CRLF & _
"HS.code: 73269098 Country of origin: EU/DE" & @CRLF & _
"EAN: 2050000286988" & @CRLF & _
" 721 0634.303.110 000 1 2,62 1 2,62 " & @CRLF & _
"O-RING" & @CRLF & _
"HS.code: 40169300 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000069956" & @CRLF & _
" 731 0634.316.304 000 1 3,77 1 3,77 " & @CRLF & _
"O-RING" & @CRLF & _
"HS.code: 39269097 Country of origin: EU/IT" & @CRLF & _
"EAN: 2050000014369" & @CRLF & _
"Goods value: 13,21 " & @CRLF & _
"Freight charges 24,40 " & @CRLF & _
"Subtotal 2.168,04 " & @CRLF & _
"Freight charges 38,85 " & @CRLF & _
"Total amount 2.206,89 " & @CRLF & _
"Terms of payment Up to 07.02.2024 you receive 2,000 % discount Up to 24.03.2024 without deduction" & @CRLF & _
"Tax free supply within the EEC in terms of §6a VAT Law." & @CRLF & _
"Packaging 2 collies Gross weight/kg 19,00 Net weight/kg 17,50 " & @CRLF & _
"Marks:7/7 " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")