import re
regex = re.compile(r"(?<=\d{4}\.\d{3}\.\d{3}.*).*\n(.+)", flags=re.MULTILINE)
test_str = ("Number\n"
"5012993885\n"
"Transport\n"
"23943538\n"
"Contact person\n"
"Lenka Boček\n"
"E-Mail\n"
"Date\n"
"24.01.2024\n\n"
"Telephone\n"
"00420 731316628\n"
" \n"
" \n"
"Your VAT No.\n"
"BG175423111\n"
" \n"
"Shipment by\n"
"Parcel service\n"
"Forwarder\n"
"UPS United Parcel Service\n"
"Item Part Number\n"
"Description\n"
"Suffix Quantity\n"
"Piece\n"
"Price/ \n"
"EUR \n"
" Per\n"
" PCE\n"
"Disc.% Amount\n"
"EUR\n"
"Customer Material / Material entered / OE-Number\n"
"Transport: 23943538\n"
"Order No.: 3192166 Your Reference: A202401241118\n"
" 11 4149.310.025 000 1 37,78 1 37,78 \n"
"PISTON\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000141478\n"
" 21 0734.401.251 000 4 3,05 1 12,20 \n"
"PISTON RING\n"
"HS.code: 73182100 Country of origin: JP\n"
"EAN: 2050000026638\n"
" 31 0750.116.391 000 1 35,50 1 35,50 \n"
"BALL BEARING\n"
"HS.code: 84821090 Country of origin: JP\n"
"EAN: 2050000088643\n"
" 41 0634.314.358 000 1 5,57 1 5,57 \n"
"O-RING\n"
"HS.code: 39269097 Country of origin: EU/IT\n"
"EAN: 2050000017476\n"
" 51 0734.401.080 000 1 5,41 1 5,41 \n"
"PISTON RING\n"
"HS.code: 73182100 Country of origin: JP\n"
"EAN: 2050000028885\n"
" 61 4139.210.082 000 1 55,70 1 55,70 \n"
"BUSH\n"
"HS.code: 73182900 Country of origin: EU/DE\n"
"EAN: 2050000111631\n"
"Number 5012993885\n"
"Date 24.01.2024\n"
"carry forward 152,16 \n"
"Item Part Number\n"
"Description\n"
"Suffix Quantity\n"
"Piece\n"
"Price/ \n"
"EUR \n"
" Per\n"
" PCE\n"
"Disc.% Amount\n"
"EUR\n"
"Customer Material / Material entered / OE-Number\n"
" 71 0734.401.277 000 1 110,41 1 110,41 \n"
"RECTANGULAR RING\n"
"HS.code: 73182100 Country of origin: QU\n"
"EAN: 2050000103230\n"
" 81 0634.313.017 000 1 0,81 1 0,81 \n"
"O-RING\n"
"HS.code: 39269097 Country of origin: EU/IT\n"
"EAN: 2050000057557\n"
" 91 4149.320.018 000 1 79,19 1 79,19 \n"
"BUSH\n"
"HS.code: 76169990 Country of origin: EU/DE\n"
"EAN: 2050000144653\n"
" 101 0750.115.518 000 1 2,16 1 2,16 \n"
"NEEDLE SLEEVE\n"
"HS.code: 84824000 Country of origin: EU/DE\n"
"EAN: 2050000086328\n"
" 111 0730.150.625 000 1 3,67 1 3,67 \n"
"THRUST WASHER\n"
"HS.code: 39269097 Country of origin: EU/DE\n"
"EAN: 2050000082290\n"
" 121 0750.115.520 000 2 5,97 1 11,94 \n"
"NEEDLE CAGE\n"
"HS.code: 84824000 Country of origin: EU/SK\n"
"EAN: 2050000116179\n"
" 131 0730.150.638 000 1 5,98 1 5,98 \n"
"THRUST WASHER\n"
"HS.code: 39269097 Country of origin: EU/DE\n"
"EAN: 2050000104367\n"
" 141 0730.150.630 000 1 12,98 1 12,98 \n"
"THRUST WASHER\n"
"HS.code: 39269097 Country of origin: EU/DE\n"
"EAN: 2050000112317\n"
" 151 0735.320.782 000 2 8,76 1 17,52 \n"
"NEEDLE CAGE\n"
"HS.code: 84824000 Country of origin: EU/SK\n"
"EAN: 2050000060595\n"
" 161 0730.150.637 000 1 4,67 1 4,67 \n"
"THRUST WASHER\n"
"HS.code: 39269097 Country of origin: EU/DE\n"
"EAN: 2050000115325\n"
" 171 0730.150.636 000 1 6,82 1 6,82 \n"
"THRUST WASHER\n"
"HS.code: 39269097 Country of origin: EU/DE\n"
"EAN: 2050000082610\n"
" 181 0730.150.639 000 1 3,55 1 3,55 \n"
"THRUST WASHER\n"
"HS.code: 39269097 Country of origin: EU/DE\n"
"EAN: 2050000054846\n"
" 191 0750.115.519 000 1 4,06 1 4,06 \n"
"NEEDLE SLEEVE\n"
"HS.code: 84824000 Country of origin: US\n"
"EAN: 2050000080418\n"
" 201 4139.333.040 000 1 2,10 1 2,10 \n"
"FIXING PLATE\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000043369\n"
"Item Part Number\n"
"Description\n"
"Suffix Quantity\n"
"Piece\n"
"Price/ \n"
"EUR \n"
" Per\n"
" PCE\n"
"Disc.% Amount\n"
"EUR\n"
"Customer Material / Material entered / OE-Number\n"
" 211 0630.513.028 000 1 1,25 1 1,25 \n"
"SNAP RING\n"
"HS.code: 73182100 Country of origin: EU/IT\n"
"EAN: 2050000007927\n"
" 221 4139.333.373 000 1 18,43 1 18,43 \n"
"DISC\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000055355\n"
" 231 4139.333.172 000 1 13,40 1 13,40 \n"
"O.CLUTCH DISC\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000139765\n"
" 241 4139.333.036 000 1 4,55 1 4,55 \n"
"I.CLUTCH DISC\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000132223\n"
" 251 4149.370.005 000 1 12,96 1 12,96 \n"
"O.CLUTCH DISC\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000134135\n"
" 261 4139.333.437 000 1 18,36 1 18,36 \n"
"DISC\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000071713\n"
" 271 4139.333.263 000 1 17,98 1 17,98 \n"
"O.CLUTCH DISC\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000104916\n"
" 281 4139.333.745 000 3 17,05 1 51,15 \n"
"O.CLUTCH DISC\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000143649\n"
" 291 4139.333.766 000 1 21,36 1 21,36 \n"
"O.CLUTCH DISC\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000081705\n"
" 301 0734.307.302 000 1 18,92 1 18,92 \n"
"LIP SEALING RING\n"
"HS.code: 84842000 Country of origin: EU/DE\n"
"EAN: 2050000176593\n"
" 311 0734.300.504 000 1 15,46 1 15,46 \n"
"PISTON RING\n"
"HS.code: 39269097 Country of origin: EU/DE\n"
"EAN: 2050000174032\n"
" 321 0734.300.503 000 1 12,19 1 12,19 \n"
"PISTON RING\n"
"HS.code: 39269097 Country of origin: EU/DE\n"
"EAN: 2050000176807\n"
" 331 0750.117.625 000 1 31,26 1 31,26 \n"
"TAPERED ROLLER BEARING\n"
"HS.code: 84822000 Country of origin: CN\n"
"EAN: 2050000123405\n"
" 341 0730.103.590 000 1 2,79 1 2,79 \n"
"WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050000109447\n"
"carry forward 658,08 4/7 \n"
"Item Part Number\n"
"Description\n"
"Suffix Quantity\n"
"Piece\n"
"Price/ \n"
"EUR \n"
" Per\n"
" PCE\n"
"Disc.% Amount\n"
"EUR\n"
"Customer Material / Material entered / OE-Number\n"
" 351 0730.103.589 000 1 2,00 1 2,00 \n"
"WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050000099366\n"
" 361 0750.117.621 000 1 32,82 1 32,82 \n"
"TAPERED ROLLER BEARING\n"
"HS.code: 84822000 Country of origin: JP\n"
"EAN: 2050000124365\n"
" 371 0730.103.362 000 1 7,67 1 7,67 \n"
"SPACER WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050000071355\n"
" 381 0730.008.417 000 1 3,02 1 3,02 \n"
"WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050006139165\n"
" 391 0730.008.418 000 1 3,02 1 3,02 \n"
"WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050000101281\n"
" 401 0730.008.420 000 1 4,31 1 4,31 \n"
"WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050000158292\n"
" 411 0730.008.423 000 1 3,02 1 3,02 \n"
"WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050000052804\n"
" 421 0634.313.016 000 2 0,34 1 0,68 \n"
"O-RING\n"
"HS.code: 39269097 Country of origin: EU/IT\n"
"EAN: 2050000024382\n"
" 431 0730.002.769 000 7 0,74 1 5,18 \n"
"WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050000109171\n"
" 441 0630.502.007 000 7 0,41 1 2,87 \n"
"CIRCLIP\n"
"HS.code: 73182100 Country of origin: CN\n"
"EAN: 2050000012969\n"
" 451 4139.306.217 000 7 7,95 1 55,65 \n"
"PIN\n"
"HS.code: 73170080 Country of origin: EU/DE\n"
"EAN: 2050000093951\n"
" 461 0501.214.850 000 1 68,29 1 68,29 \n"
"OIL DIPSTICK\n"
"HS.code: 90261089 Country of origin: EU/DE\n"
"EAN: 2050000096211\n"
" 471 4139.301.617 000 1 0,70 1 0,70 \n"
"TAB WASHER\n"
"HS.code: 73182100 Country of origin: EU/DE\n"
"EAN: 2050000084041\n"
" 481 0769.151.009 000 1 1,87 1 1,87 \n"
"O-RING\n"
"HS.code: 39269097 Country of origin: EU/IT\n"
"EAN: 2050011096262\n"
"carry forward 849,18 5/7 \n"
"carry forward 849,18 \n"
"Item Part Number\n"
"Description\n"
"Suffix Quantity\n"
"Piece\n"
"Price/ \n"
"EUR \n"
" Per\n"
" PCE\n"
"Disc.% Amount\n"
"EUR\n"
"Customer Material / Material entered / OE-Number\n"
" 491 0501.210.798 000 1 10,08 1 10,08 \n"
"SCREEN INSERT\n"
"HS.code: 87084099 Country of origin: EU/IT\n"
"EAN: 2050000005534\n"
" 501 0735.368.102 000 1 70,18 1 70,18 \n"
"AXIAL ROLLER BEARING\n"
"HS.code: 84825000 Country of origin: EU/SK\n"
"EAN: 2050000123191\n"
" 511 0635.330.035 000 2 25,15 1 50,30 \n"
"BALL BEARING\n"
"HS.code: 84821090 Country of origin: IN\n"
"EAN: 2050000051746\n"
" 521 0635.900.523 000 1 8,94 1 8,94 \n"
"AX.NEEDLE CAGE\n"
"HS.code: 84829900 Country of origin: EU/DE\n"
"EAN: 2050000012099\n"
" 531 0634.402.140 000 1 3,22 1 3,22 \n"
"R-RING\n"
"HS.code: 73262000 Country of origin: JP\n"
"EAN: 2050000102523\n"
" 541 0501.213.150 000 2 52,97 1 105,94 \n"
"I.CLUTCH DISC\n"
"HS.code: 87084099 Country of origin: EU/PL\n"
"EAN: 2050000017186\n"
" 551 0501.334.482 000 2 91,72 1 183,44 \n"
"OUTER CLUTCH DISK\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050011198423\n"
" 561 0501.334.483 000 2 116,68 1 233,36 \n"
"OUTER CLUTCH DISK\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050011198416\n"
" 571 0750.106.074 000 1 124,26 1 124,26 \n"
"CUP SPRING\n"
"HS.code: 73209030 Country of origin: EU/DE\n"
"EAN: 2050000062230\n"
" 581 0501.320.311 000 1 16,72 1 16,72 \n"
"SEALING RING\n"
"HS.code: 40169300 Country of origin: EU/IE\n"
"EAN: 2050000006746\n"
" 591 0501.320.312 000 1 27,75 1 27,75 \n"
"SEALING RING\n"
"HS.code: 40169300 Country of origin: EU/IE\n"
"EAN: 2050000021688\n"
" 601 0634.313.840 000 1 15,01 1 15,01 \n"
"O-RING\n"
"HS.code: 39269097 Country of origin: EU/IT\n"
"EAN: 2050000043406\n"
" 611 0736.101.046 000 1 3,91 1 3,91 \n"
"CAP SCREW\n"
"HS.code: 73181568 Country of origin: EU/DE\n"
"EAN: 2050000066542\n"
" 621 0730.005.592 000 1 11,45 1 11,45 \n"
"WASHER\n"
"HS.code: 73182200 Country of origin: EU/DE\n"
"EAN: 2050000028366\n"
"carry forward 1.713,74 6/7 \n"
"Item Part Number\n"
"Description\n"
"Suffix Quantity\n"
"Piece\n"
"Price/ \n"
"EUR \n"
" Per\n"
" PCE\n"
"Disc.% Amount\n"
"EUR\n"
"Customer Material / Material entered / OE-Number\n"
" 631 0634.313.628 000 2 1,76 1 3,52 \n"
"O-RING\n"
"HS.code: 39269097 Country of origin: EU/IT\n"
"EAN: 2050000092503\n"
" 641 0501.221.565 000 1 111,27 1 111,27 \n"
"PISTON\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050010978361\n"
" 651 4139.347.284 000 1 1,32 1 1,32 \n"
"GASKET\n"
"HS.code: 40169300 Country of origin: EU/DE\n"
"EAN: 2050000074042\n"
" 661 4139.347.275 000 2 0,69 1 1,38 \n"
"GASKET\n"
"HS.code: 40169300 Country of origin: EU/DE\n"
"EAN: 2050005683713\n"
" 671 4139.347.273 000 2 77,93 1 155,86 \n"
"CONN.PART\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050001798787\n"
" 681 4139.298.939 009 1 52,37 1 52,37 \n"
"SEALING RING KIT\n"
"HS.code: 84849000 Country of origin: EU/DE\n"
"EAN: 4053202129457\n"
" 691 4139.298.943 009 1 115,37 1 115,37 \n"
"SEAL KIT\n"
"HS.code: 84849000 Country of origin: EU/DE\n"
"EAN: 4053202129426\n"
"Goods value: 2.154,83 \n"
"Freight charges 14,45 \n"
"Transport: 23943551\n"
" 711 0630.361.026 000 1 6,82 1 6,82 \n"
"SEALING CAP\n"
"HS.code: 73269098 Country of origin: EU/DE\n"
"EAN: 2050000286988\n"
" 721 0634.303.110 000 1 2,62 1 2,62 \n"
"O-RING\n"
"HS.code: 40169300 Country of origin: EU/IT\n"
"EAN: 2050000069956\n"
" 731 0634.316.304 000 1 3,77 1 3,77 \n"
"O-RING\n"
"HS.code: 39269097 Country of origin: EU/IT\n"
"EAN: 2050000014369\n"
"Goods value: 13,21 \n"
"Freight charges 24,40 \n"
"Subtotal 2.168,04 \n"
"Freight charges 38,85 \n"
"Total amount 2.206,89 \n"
"Terms of payment Up to 07.02.2024 you receive 2,000 % discount Up to 24.03.2024 without deduction\n"
"Tax free supply within the EEC in terms of §6a VAT Law.\n"
"Packaging 2 collies Gross weight/kg 19,00 Net weight/kg 17,50 \n"
"Marks:7/7 \n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")