#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)var .* = '(.*?)';"
Local $sString = "<script type="text/javascript">" & @CRLF & _
"var NVRAMyandex = 'Close'; NVRAM_wan_static_dns_profile_yandex = (NVRAM_wan_static_dns_profile_yandex !='') ? NVRAM_wan_static_dns_profile_yandex : 'basic';" & @CRLF & _
"var FancyboxI18nClose = 'Close';" & @CRLF & _
"var FancyboxI18nNext = 'Next';" & @CRLF & _
"var FancyboxI18nPrev = 'Previous';" & @CRLF & _
"var PS_CATALOG_MODE = false;" & @CRLF & _
"var ajaxsearch = true;" & @CRLF & _
"var attribute_anchor_separator = '-';" & @CRLF & _
"var blocksearch_type = 'top';" & @CRLF & _
"var combinationsFromController = {"163972":{"attributes_values":{"15":"40"},"attributes":[75],"price":0,"specific_price":false,"ecotax":0,"weight":0.6,"quantity":1,"reference":"IDP20059--IDPA163972","unit_impact":0,"minimal_quantity":"1","date_formatted":"","available_date":"","id_image":-1,"list":"'75'"}};" & @CRLF & _
"var comparator_max_item = 0;" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")