# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"var .* = '(.*?)';"
test_str = ("<script type=\"text/javascript\">\n"
"var NVRAMyandex = 'Close'; NVRAM_wan_static_dns_profile_yandex = (NVRAM_wan_static_dns_profile_yandex !='') ? NVRAM_wan_static_dns_profile_yandex : 'basic';\n"
"var FancyboxI18nClose = 'Close';\n"
"var FancyboxI18nNext = 'Next';\n"
"var FancyboxI18nPrev = 'Previous';\n"
"var PS_CATALOG_MODE = false;\n"
"var ajaxsearch = true;\n"
"var attribute_anchor_separator = '-';\n"
"var blocksearch_type = 'top';\n"
"var combinationsFromController = {\"163972\":{\"attributes_values\":{\"15\":\"40\"},\"attributes\":[75],\"price\":0,\"specific_price\":false,\"ecotax\":0,\"weight\":0.6,\"quantity\":1,\"reference\":\"IDP20059--IDPA163972\",\"unit_impact\":0,\"minimal_quantity\":\"1\",\"date_formatted\":\"\",\"available_date\":\"\",\"id_image\":-1,\"list\":\"'75'\"}};\n"
"var comparator_max_item = 0;\n"
"</script>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.