re = /<b><font[^>]*>(.*?)<\//m
str = '<div class="list-group font-12"><div class="panel panel-default"><div class="panel-heading"><h3 class="panel-title"><a href="https://kazua.net/bbs/download.php?bo_table=free&wr_id=4297amp;no=0"><span class="label label-primary pull-right view-cnt">132</span><i class="fa fa-download"></i> <b><font color=428bca>미운 우리 새끼.E97.180722.360p-NEXT.mp4.torrent</font></b> (71.2K) <span class="en font-11 text-muted"><i class="fa fa-clock-o"></i> 13시간전</span></a></h3></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end