package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]\.[0-9]{2}`)
var str = `3
3.55
5.2
7.37520
506.035
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}