$re = '/[0-9]\.[0-9]{2}/m';
$str = '3
3.55
5.2
7.37520
506.035
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);